Back to overview
Degraded
Upstream provider issues
Aug 22 at 02:20am BST
Affected services
Dedicated Server
Resolved
Aug 22 at 09:33am BST
Issue has been resolved.
Affected services
Created
Aug 22 at 02:20am BST
We have been made aware by our upstream provider that they are experiencing suspected power issues within their facilities that may affect our services. Although all our services are currently operational, we are monitoring the situation and will react to any downtime as appropriate.
Affected services